VMware: HA Advanced Runtime Info

A few minutes ago I took a quick look at the summary tab of my cluster. In the VMware HA box I noticed┬áthe following line: “Current Failover Capacity: 0 hosts”…

After opening the “HA Advanced Runtime Info” link it turns out I had only 80 HA Slots in my cluster (256 MHz, 2 vCPU’s and 2048MB RAM). After some research I detected 1 VM with a memory reservation (2048MB), after I removed the reservation the available slots jumped from 80 to 329 ­čÖé

The HA box now say “Current Failover Capacity: 4 hosts”. Just another example why you don’t want to use reservations in a┬ávSphere cluster.

For more details and technical background regarding VMware HA I suggest reading the “HA Deepdive” article written by Duncan Epping @ yellow-bricks.com:┬áhttp://www.yellow-bricks.com/vmware-high-availability-deepdiv/

[ad#postad]

VMware: Upgrade ESX vSphere 4.0 naar 4.0 Update1

Zo vandaag heb ik de laatste vSphere 4.0 host geupgrade naar 4.0 Update 1. Het proces is erg makkelijk, het staat beschreven in de vSphere Upgrade Guide Update 1 maar het komt hierop neer;

  1. Kopieer het bestand ESX4-0.0-update01.zip naar je ESX host d.m.v. WinSCP of de datastore browser
  2. Maak de directory /var/update aan en verplaats ESX4-0.0-update01.zip┬ánaar deze locatie┬ád.m.v.┬áde commando’s;
    # mkdir /var/update
    # mv ESX4-0.0-update01.zip /var/update
    # cd /var/update
  3. Vervolgens kan je de update uitvoeren met esxupdate
    1. Direct vanuit het zip bestand;
      # esxupdate -bundle=ESX4-0.0-update01.zip update
    2. Of eerst unpacken en dan upgraden
      # unzip ESX4-0.0-udpate01.zip
      # esxupdate -m metadata.zip update
  4. Nu even rebooten en klaar.

[ad#postad]

VMware: Intel 82571 NIC op IBM x3850 vSphere server

Vandaag liep ik tegen een probleem aan dat mijn (Intel) netwerkkaarten opeens geen link meer hadden naar het netwerk. Eerst dacht ik aan een switch probleem maar bij het aansluiten van een andere switch hield ik het probleem. De on-board broadcom NetXtreme kaarten hadden wel gewoon connectie.

Na een zoekopdracht via google op het type Intel kaart wat ik in mijn server heb zitten kwam ik volgend kb artikel van VMware tegen;

pNIC loses connectivity on IBM x3850 servers with Intel 82571 NICs

Laat mijn server nou net een IBM x3950 M1 zijn… Na het uitvoeren van onderstaand commando en een reboot was het probleem verholplen…

esxcfg-module -s IntMode=0,0,0,0 e1000e

[ad#postad]