Update SynoCommunity packages after DSM 4.2 upgrade

Yesterday I’ve updated my Synology DS 410 to DSM 4.2 Beta. After the update I went to the ‘Package Center’ to upgrade my installed packages. All the Synology provided packages upgraded nicely but a few packages from the SynoCommunity (Sabnbd, sickbeard and CouchPotato) failed with the following error;

PythonErrorPC

“Please run “Python” before installing this package.”

Because the Python package can’t run this must be some sort of compatibility issue. After performing some tests I came up with the following procedure to fix this problem;

  1. SSH to your DS (by using Putty or some other terminal application)
  2. Open the file “/var/packages/python/scripts/start-stop-status”
  3. Change the line “exit 1” under “status)” to “exit 0”, your configuration file then should look like this;
    Python-start-stop-status
  4. Save the file and try upgrading the SynoCommunity packages again

PCupgradeComplete

30 thoughts on “Update SynoCommunity packages after DSM 4.2 upgrade

  1. I can’t see any directories when i login as a root…only I see the directories when I login as a admin

  2. Perfect! This worked for me. Though as a beginner I needed some trial and error to edit a file from the command prompt (last time I did this was on my Dad’s Olivetti computer, running NO Windows and equiped with a 20MB harddrive).

    For the noobs (hehe):
    – login via SSH: “ssh root@
    – enter admin password
    – go up one directory (“cd ..”)
    – type “chdir var/packages/python/scripts”
    – type “vi start-stop-status”
    – make sure you are in edit mode (I believe I had to hit the ESC button once)
    – move cursor to right position and change 1 into 0
    – type “:” –> this can be done anywhere as it brings you to the bottom command-area
    – type “wq” (I guess this means write & quit)

    That’s it 😉

    1. text between brackets seems to get lost…
      First line must be “- login via SSH: “ssh root@[your-ip-address]”

  3. I tried this and I really appreciate the help, I managed to edit the file and install packages OK but still cant open them up in a browser as it says it wont connect but packages are running. I am using ds212j with dsm 4.2 beta which I suspect might be the issue. just got the ds and updated it straight away but perhaps should have waited, any ideas anyone.
    Kind regards
    Venture

  4. Ik heb de file gewijzigd en heb nu exact dezelfde staan zoals in de screenshot daarna voor de zekerheid ook nog geherstart echter blijf ik nog dezelfde melding krijgen, zijn er nog meer opties?

  5. This worked for me. Took me a few to get back up to speed on VI but I got it taken care of. Thanks so much for this tip!

  6. renamen of the unpacked map is not good working.

    FOUT: ld.so: object ‘/usr/syno/synoha/lib/libsynoha.so.4’ from /etc/ld.so.preload cannot be preloaded: ignored.

  7. Hallo na veel zoeken is het mij gelukt om dit uit te voeren. Op het moment dat ik wil saven met :wq dan krijg ik de melding dat de file readonly is. Is heir een oplossing voor

  8. Hallo ik ben totaal nieuw met putty of iets anders. Het lukt mij nu om dmv putty connectie te maken. maar moet ik dan het script letterlijk overtypen

  9. Hey Rob,

    I connected as Root, but I’m unable to edit the file in VI, it doesn’t say anything about the file being read-only which you’d normally expect, but I can’t edit it. When I try to turn the 1 in to a 0 it Putty jumps to the beginning of the line.

    Do you happen to know how to fix this?

    Cheers,
    Jorde

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.